Saturday, March 9, 2024

TCP/IP Packet Format

 

Data Encapsulation

​

TCP data is encapsulated in an IP datagram.


TCP Header - RFC 173

​


UDP Header - RFC 768

​


IP Header - RFC 791, 1349, 2474, 3168

​

IPv6 Header - RFC 2460 (IPv6 Spec)

​


References

​

IPv6 packet (Wikipedia)
Packet Header Cheat Sheets
IPv6 cheat sheet
Understanding the IPv6 Header (Pearson)
How Traceroute Works (IP With Ease)
Ethernet frame (Wikipedia)


No comments: